Resolve error "SEVERE: Input Answer Id: N/A|Input File Name: N/A|error processing record with id: null" in EngageOne

Issue

After batch processing runs for some time, the following error occurs:
SEVERE: Input Answer Id: N/A|Input File Name: N/A|error processing record with id: null
Throwable occurred: java.lang.NullPointerException

Cause

The issue is the number of input records.

Resolution

UPDATED: November 13, 2017
The optimal NA batch size is 20-50k input records.

For jobs larger than this it is recommended to break them into smaller batches, each not exceeding the 20-50k recommended input records. (EO-5287)