'The partner transaction manager has disabled its support for remote/network transactions' message in EngageOne Inform

Product Affected:  MAIL360 Data Manager™ 2.4.0
Environment Details  Product Feature: Mail360 Services
Operating System: Windows Server 2008 Enterprise
Database: SQL server 2008

 

Issue

Error 'System.Transactions.TransactionException: The partner transaction manager has disabled its support for remote/network transactions' is being observed in the bus log of EngageOne Inform.

Cause

This can be caused due to wrong MSDTC settings.

Resolution

UPDATED: November 6, 2019

Refer to the following steps to correct the MSDTC settings :

  1. Verify the "Distribute Transaction Coordinator" Service is up and running. If it is not running then :
    • Go to "Administrative Tools > Services"
    • Turn on the "Distribute Transaction Coordinator" Service
  2. Go to "Administrative Tools > Component Services"
  3. On the left navigation tree, go to "Component Services > Computers > My Computer" (double click and wait as some nodes take time to expand).
  4. Right-click on "My Computer", select "Properties"
  5. Select "MSDTC" tab
  6. Click "Security Configuration"
  7. Check "Network DTC Access", "Allow Remote Client", "Allow Inbound/Outbound", "Enable TIP"
  8. The service will restart

If the error still persists, then " REBOOT SERVER "

Final resolution – Have to enable DTC on the SQL Server. When migrating to a new server the DTC has to be changed to the correct setting.