Product Feature: Installation / Upgrade
Operating System: Linux
Version: 9 SP1
Operating System: Linux
Version: 9 SP1
Issue
User is running a web service in which they are running into this error message: OLockException: No more resources available in pool
User edits \server\app\conf\ orientdb-server-config.xml file by editing the db.pool.max by increasing the value to 30 or 100. Increasing the db.pool.max value does not help and the OLockExceptions still occurs.
User edits \server\app\conf\ orientdb-server-config.xml file by editing the db.pool.max by increasing the value to 30 or 100. Increasing the db.pool.max value does not help and the OLockExceptions still occurs.
Cause
After some investigation, items are not being added to a cache that should be. Therefore, each request for information loads that information from the Orient database. Also, the user has a custom security role that has access to certain db resources and the ability to execute services.
Resolution
UPDATED: March 27, 2017Apply patch Spectrum 9.0.0 S21 patch to resolve this issue. The patch can be downloaded from the G1 support website.