Issue
Following error message is encountered while installing or upgrade the Portrait Dialogue:
Error 1721.There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.
Error 1721.There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.
Cause
This could be caused due to either of following reasons:
1) 32 bit flag is not enabled in the Application pool used.
2) Application pool is not pointing to supported .Net Framework.
1) 32 bit flag is not enabled in the Application pool used.
2) Application pool is not pointing to supported .Net Framework.
Resolution
UPDATED: December 19, 20171. Check for IIS 32 bit application is enabled on you system.

2. Ensure Application pool uses .Net version supported (as mentioned in section 'Installation pre-requisites' in Portrait Suite installation guide) by Portrait Dialogue.
To know this, Navigate to Administrative tools->IIS Manager->Application Pools.
- Navigate to Administrative tools -> IIS Manager -> Application Pools.
- Select Advance settings.
- Refer following screenshot.
If not then:
-
Open a command prompt and navigate to the %systemdrive%\Inetpub\AdminScripts directory.
- Type the following command: cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 1
- Press ENTER.
Note: Ensure that the IIS application pool used to run the Dialogue Web Applications is configured with a Managed Pipeline Mode of Classic. By default, Dialogue Web Applications use the DefaultAppPool application pool.
2. Ensure Application pool uses .Net version supported (as mentioned in section 'Installation pre-requisites' in Portrait Suite installation guide) by Portrait Dialogue.
To know this, Navigate to Administrative tools->IIS Manager->Application Pools.