Filtering on datetime field not giving expected output in Sagent

Product Feature: Design Studio, Weblink client

Issue

Filtering records for specific date in Analysis sink transform does not change the output.

Cause

This is a defect in the releases prior to Sagent 6.8.7.

Resolution

UPDATED: September 3, 2019
This has been fixed in Sagent 6.8.7 so upgrade to 6.8.7 or latest release (6.8.13) should resolve this problem. If upgrade is not possible, follow this workaround: 
 
  • Go to control panel and then “Region and language”. 
  • Click on “Formats” tab and then go to “Additional Settings”. 
  • Go to “Time” tab and change the “Long time” format to “hh:mm:ss”. 
  • Go to “Date tab” and change the “Short Date” to “mm/dd/yyyy”. 
  • Restart the Design Studio. 
 
Steps to change the Long time and Short date may differ on different operating systems. Here mentioned steps are for Windows 7 operating system. 
Changing the system date format will reflect to in all display sinks and all the places where system date is considered in Sagent Data Flow.