Issue
When the following control parameter (highlighted in yellow below) is added to any channel plug-in, the Visual Dialogue adds a drop list for that 'Priority' parameter in any corresponding message template.
[part of the script]
[part of the script]
MyPlugin function GetControlParamDefs( ControlParamDefs ) { ... //Params to be merge per message ControlParamDefs.AddParamWithDisplayedNameEx("Cellular", "[#MH14103]Cellular", "", true, true, true); ControlParamDefs.AddParamWithDisplayedName("FromNumber", "[#MH14104]From number", "MH", true, true); ControlParamDefs.AddParamWithDisplayedName("Priority", "Message priority", "", true, true); }
Cause
From version 5.2 onwards, the name 'Priority' is a reserved control parameter name.
Resolution
UPDATED: March 23, 2017The only fix for this is to change the name Priority to something else, for example Priority_level.
If the previously highlighted text was changed to this:
Then the outcome will then be as expected and the template field for 'Message priority' will take a text value.

If the previously highlighted text was changed to this:
ControlParamDefs.AddParamWithDisplayedName("Priority_level", "Message priority", "", true, true);
Then the outcome will then be as expected and the template field for 'Message priority' will take a text value.