Resolve error "Failed to import file" when importing PDF in Doc1 Designer

Product Feature: Publication Editor

 

Issue

Unable to import the EngageOne Interactive generated PDF into Designer.Error message recieved :
User-added image

Cause

Unable to import PDF to designer.

The issue is with your PDF version. Go to adobe reader, open your PDF and click on FILE->PROPERTIES
If it shows any version more than 1.4 , it’s not supported.

The import of PDF only supports up to PDF 1.4 for the libraries we have with Designer.



 

Resolution

UPDATED: August 1, 2017
Now we have a workaround, using a small command you can downgrade the PDF version. It might import successfully, but due to new constructs of PDF, it may not import (view wise) in best manner.

GSVIEW32 ghost script which you can separately download, downgrades the version of many documents like PDF.
It has no relation to Doc1, it
 is just a workaround which might suit some customers.

Support and Engineering  has already investigated (a few months back) and as we explained, Doc1 uses libraries that wont support beyond 1.4 version. Doc1 code need to upgrade the PDF linking Brailles which is third party linkage.There is no plan to fix this issue. It is under backlog.

It is an existing Enhancement already raised few months back. Unfortunately there is no plan to fix it from engineering.