product affected: MapInfo Pro™
Issue
Customer opens a layout and goes to file>page setup and the printer button is missing. Only OK, Cancel, and Help are available. The "Printer" button to select a printer is not displayed.
Printers and drivers are available when going to file>print to pdf or other programs.
Printers and drivers are available when going to file>print to pdf or other programs.
Cause
The problem can occur due to installing on an Unsupported operating system or service pack.
Resolution
UPDATED: December 4, 2019- Check that the operating system on which MapInfo Pro is installed and make sure it is a supported operating system for that version of MapInfo Professional.
- Go to Start>Programs>MapInfo>MapInfo Professional and RIGHT-click on the MapInfo Professional shortcut menu item.
Select Properties>Compatibility tab.
If the compatibility option is checked and an older operating system such as XP or Vista is selected, uncheck the compatibility option, click OK, and restart MiPro. The Printer button should now be visible.
- Go to Start>Programs>MapInfo>MapInfo Professional and RIGHT-click on the MapInfo Professional shortcut menu item.
Select Properties>Compatibility tab.
If the compatibility option is checked and an older operating system such as XP or Vista is selected, uncheck the compatibility option, click OK, and restart MiPro. The Printer button should now be visible.