Resolve "The current license is NOT valid for this version of Discover"

Products affected: MapInfo Discover bundle - local (disk-based) license

Issue

The following error appears when starting MapInfo Discover:

The current license is NOT valid for this version of Discover.
The license will expire in 20 days.
You MUST upgrade your license to continue using this product after expiry.
Select "YES" to request upgrade activation.
Select "NO" to use the product within the grade period.

Cause

An older version of license file is being used to run a newer version of the software.

Resolution

UPDATED: April 28, 2017

If entitled for upgrade,
 

1. Select Yes.
2. When presented with the Activate License tab of the License Manager, populate all the fields (e.g. customer number, serial number, name and email address).
3. Click on the Automatically submit request and activate button. The license will be upgraded within 20 seconds. 



If not entitled for upgrade, select No.
You will be able to use the product within the grace period, after which you will have to renew your maintenance agreement or downgrade the software to the version your license is entitled to.


If the issue is still not resolved, contact client support.