Issue
The license expired for e2serverd and e2loaderd 2 weeks prior to the customer needs to manually stop services but services continued to work normally. The license for e2renderd had not expired.
When the client manually stopped the services , he was not able to start it again .
When the client manually stopped the services , he was not able to start it again .
Cause
e2loaderd log showed :
15:18:30 open log, date [2014/07/21], file [D:\Program Files\PBBI\e2Vault\server\log\e2serverd.20140721.151830.4980.log]
15:18:30 e2 Vault Server 5.4M4p0229
15:18:30 (C) Copyright 2010 Pitney Bowes Software Inc.
15:18:30 starting
15:18:30 ERROR: You are not licenced to run e2 Vault
15:18:30 stopped
15:18:30 close log, shutting down
It looks like it is only checking for server/loader expiry during process start up.
The rendering engine checks it's expiry date on each rendering operation but (1) the result is cached so it won't always expire immediately and (2) the licence may have an expiry on server but not render (as is the case here).
Resolution
UPDATED: September 25, 2017Give the customer a temporary license and contact the Sales engineer to provide the permanent license key to the customer.