Resolve error "This dataflow has been checked out to ' '. Changes can be made to the the dataflow, but it cannot be saved or deleted." in Spectrum Enterprise Designer

Product Feature: Spectrum Server

Issue

When opening a Data Flow or Process Flow in Spectrum Enterprise Designer, we see the following error message.
 
User-added image

Unable to check out this dataflow

This dataflow has been checked out to '<Spectrum User Name> '. Changes can be made to the the dataflow, but it cannot be saved or deleted.

Alternatively:

Unable to check out this ProcessFlow

 

Cause

The issue is that the Data Flow or Process Flow was checked out by another user. 

Resolution

UPDATED: October 18, 2017

A quick remedy to the issue would be to do the following:
 

- Log into Enterprise Designer as the user that has the .DF or .PF logged out.
- Open the .DF or .PF in question.
- Close the .DF or .PF in question.
- Close Enterprise Designer.
- Log in as the other user and reopen the .DF or .PF.