'CaughtServerLoopingException' message in EngageOne Vault

Issue

The following error is observed on searching for an account that has more than 9000 results in EngageOne Vault client:
Error Message: CaughtServerLoopingException 
Request URI: /ServiceWeb2/Interface 
Exception: com.g1.e2.vault.ServerLoopingException: Seems Server is looping when getting all documents for 
[db=pbi, acct=19508480860, search-window-size =9000]; please check Server to find out Document size for
this ACCT, change search-window-size and try again 
Exception type class com.g1.e2.vault.ServerLoopingException

Cause

This issue is identified as a defect in the EngageOne Vault version prior to 6.1m1p148.

Resolution

UPDATED: January 28, 2020
Upgrade to EngageOne Vault  6.1m1p148 and later releases. There is a parameter of 'maxHits4Document' in web.xml which is used to control the DATE string number in the drop-down list control.
 
Settings that can control search/looping behaviour are:  (in the web.xml)
- <context-param>
  <description>Maximum number of search results to display.</description>
  <param-name>maxresults</param-name>
  <param-value>20</param-value>
  </context-param>
- <context-param>
  <description>Maximum number of document retrieving</description>
  <param-name>maxHits4Document</param-name>
  <param-value>100</param-value>
  </context-param>