Resolve Confirm System Agent error: No setting found for ConnectionList

Product Feature: Asset Register

Operating System: Windows XP Pro
 

Issue

The following log entry will be shown in the Confirm System Agent: “<AGENT>:Error: No setting found for ‘ConnectionList’”. An example of such an error can be seen in the screenshot below:

Log entry showing no setting found for ConnectionList

Cause

This error is thrown because the Confirm System Agent is lacking database connection settings.

Resolution

UPDATED: November 20, 2017
In the Confirm System Agent click on the Options button:

Image showing System Agent Options button

To the right of the Database box click on the Add button:

Image showing the Add database button
 
You will then have to supply the connection information for the database you wish to use. Once the settings have been made and the Confirm System Agent has been restarted the error messages in the log should no longer appear.