Resolve error "The snapshot you are using is from a newer or unsupported version of the database engine" when importing from DOC1 V5.1 into V6

Product Feature: Snapshot

Issue

Unable to import a snapshot from Doc1 V5.1 into V6

Attempting to import a snapshot from V5.1 into a V6 installation that is using SQL 2012 gives the following error:

User-added image

Cause

This is because of incompatibilities in the databases used by V5.1, and SQL2012.

Resolution

UPDATED: November 2, 2017
The snapshot (or database) needs to be upgraded through Doc1 5.6 that is using a later version of SQL (suggest SQL2008 R2).

This snapshot when exported again from the 5.6 environment will now import into V6 using SQL 2012.