Resolve "ERROR 70129: unable to read file attributes for file " while accessing account in EngageOne Vault

Product Feature: General

Issue

New case :Database exception while acessing vault account

Server logs shows 
 
14:21:35 127.0.0.1:50963 <storage1> storage.docdata request, file [20111027113845-grn-energypost-ps-70e64e74f964f5479da8171f0e6744e0], offset [00000050000013A7]
14:21:35 127.0.0.1:50963 <storage1> ERROR 70129: unable to read file attributes for file [storage\2011\10\27\20111027113845-grn-energypost-ps-70e64e74f964f5479da8171f0e6744e0.drd], error [3]
14:21:35 127.0.0.1:50963 <storage1> storage.docdata failed, status [70129]
14:21:35 127.0.0.1:50963 <database1> database.search failed, status [70129]
 

Cause

The problem is that the database list is not found by the server.

Resolution

UPDATED: November 14, 2017
As verified in web client only default database is visible. which again is an issue.
 
To resolve you must clear your Vault first :
 
Remove all entries from below folders : \server\docdata , \server\pagedata ,\server\index. \server\process, \server\, \server\work

Make necessary changes to profile and databse.INI


Restart all services.

Customer was able to view database list then.