Product Feature: Installation / Upgrade
Issue
The following error is thrown while running sagent plans:
Error during block memory allocation. A memory extent cannot be allocated. DC -- 0x1, DC -- 0x72 {SADCAGNT.EXE - 0000018F - 7/23/2014 11:46:45.602} WinError: 8 Error while processing the data for the step 'Subplan-Get Email and Mobile\AutomaticDiskSortStep-Subplan-Get Email and Mobile\Join 2(1)' Error during block memory allocation. A memory extent cannot be allocated. DC -- 0x1, DC -- 0x72 {SADCAGNT.EXE - 0000018F - 7/23/2014 11:46:45.602} WinError: 8 Error while processing the data for the step 'Subplan-Get Email and Mobile\AutomaticDiskSortStep-Subplan-Get Email and Mobile\Join 2(1)' Error during block memory allocation. A memory extent cannot be allocated. DC -- 0x1, DC -- 0x72 {SADCAGNT.EXE - 0000018F - 7/23/2014 11:46:45.602}
DFS memory also shot up when the error was encountered.
Error during block memory allocation. A memory extent cannot be allocated. DC -- 0x1, DC -- 0x72 {SADCAGNT.EXE - 0000018F - 7/23/2014 11:46:45.602} WinError: 8 Error while processing the data for the step 'Subplan-Get Email and Mobile\AutomaticDiskSortStep-Subplan-Get Email and Mobile\Join 2(1)' Error during block memory allocation. A memory extent cannot be allocated. DC -- 0x1, DC -- 0x72 {SADCAGNT.EXE - 0000018F - 7/23/2014 11:46:45.602} WinError: 8 Error while processing the data for the step 'Subplan-Get Email and Mobile\AutomaticDiskSortStep-Subplan-Get Email and Mobile\Join 2(1)' Error during block memory allocation. A memory extent cannot be allocated. DC -- 0x1, DC -- 0x72 {SADCAGNT.EXE - 0000018F - 7/23/2014 11:46:45.602}
DFS memory also shot up when the error was encountered.
Cause
The error was encountered just once. There is not much of the information available in logs. The user is running 32-bit Sagent. Problem seems to be with releasing of memory blocks.
Resolution
UPDATED: December 5, 2017This is just one of the incident and a simple restart of DFS service will resolve the problem. The user need to monitor the system and report if they see such an error again. The user also has a server restart policy already employed which should help releasing any unnecessary resources.
If the issue is persistent, contact Software Support.
If the issue is persistent, contact Software Support.