Resolve "ERROR 19631: unable to open file [1] [GetLastError 2]" while uploading a file in EngageOne Vault, formerly e2vault

Issue

User receives the following error while uploading a file in EngageOne Vault, formerly e2vault:

ERROR 19631: unable to open file [1] [GetLastError 2] while uploading a file in doc1 archive(e2vault)

Cause

GetLastError returns 2 when file is not found on the specified path.

In this specific case it was happening because customer had not specified the name file to be compressed in the JRN in the 'D' record (which is why process was not able to find it).


 

Resolution

UPDATED: November 14, 2017
When the file is specified the issue resolves itself as shown below in bold in the JRN 'D' record:


J|BT_SOE_XLS_Special_Charges_FILES_TEST|XXXXXXXXXXX
A|INVOICE|XXXXXXXXXXXXXXXXX
A|INDATE|DD/MM/YYYY_:_:_:_XXXXXXXXXXXXXXX
A|DOCTYPE|EXCEL
A|DATABASE|SOE_ICO_11_10
A|CUSREF|Lync
D|LYNC_GBP|XXXXXXXX|BT_SOE_XLS_TEST_FILES_XXXXXXXXXXX_test_AOCxls.xls|Mr. X  _:_:_:_XXXXXXXXXXXXXXXXXXX|XXX/A/XXXXXX XXXX-XXXX-XXX  City Country:_:_:_XXXXXXXXXXXXXX|XXXXXXXXXXXXXXX|CSV|