Resolve "Unable to validate your license due to error 880002" when opening MapInfo Pro on a Citrix Environment with App-V

Products affected: MapInfo Pro™

Issue

The following error appears "Unable to validate your license due to error 880002" when opening MapInfo™ Pro on a Citrix Environment with App-V.

Cause

MapInfo Pro™ is not officially supported on Citrix with App-V.

Resolution

UPDATED: December 3, 2019
A potential workaround to the issue is as follows:
  1. Close MapInfo Pro™
  2. Open the Registry Editor (Start > Run > type: regedit)
  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FLEXnet Licensing Service\Security and rename it to Security_original
  4. Close the Registry Editor
Please note that as MapInfo Pro™ is not officially supported on Citrix with App-V, customers wishing to use this workaround will take responsibility for the changes made to the registry.