The SendPro C Lite, SendPro C, SendPro+ (2H00, 8H00) screen is frozen on the clock screen

Products affected: SendPro® C Lite, SendPro® C, SendPro®+ (2H00, 8H00)

Issue

The SendPro C Lite, SendPro C, SendPro+ (2H00, 8H00) screen is frozen on the clock and is unresponsive.

Cause

There may be an issue with the tablet battery.

Resolution

UPDATED: May 22, 2020
Restart the device:
  1. Unplug the power cable. The screen should turn off after 10 seconds.
  2. Wait 2 minutes.
  3. Plug the power cable back in, ensuring that it is plugged directly into a wall outlet.
  4. Quickly tap and release the power button to turn the meter back on.
Leave the device plugged in and powered on for two hours. If after two hours the display still shows the clock screen, contact technical support using the Contact Us options below.