"Street must be no longer than 40 characters" or "Address must be no more than 100 characters" message in SendPro Online or PitneyShip

If you get the message "Street must be no longer than 40 characters" or "Address must be no more than 100 characters", it is because one or more lines in your sender or recipient address is longer than 40 characters (SendPro Online) or 100 characters (PitneyShip).
Products affected: Connect+ 500W®, Connect+ 1000®, Connect+ 2000®, Connect+ 3000®, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online, PitneyShip™

Issue

When entering an address in SendPro Online or PitneyShip, the message "Street must be no longer than 40 characters" or "Address must be no more than 100 characters" appears. The software may also become frozen.

Cause

One or more lines in the sender or recipient address is longer than 40 characters (including spaces) for SendPro Online or 100 characters (including spaces) for PitneyShip.

Resolution

If SendPro Online or PitneyShip is still working

Reduce all lines of the sender and recipient address to be 40 characters or less for SendPro Online or 100 characters or less for PitneyShip, including spaces. If the address cannot be shortened, separate it into more than one line.

If SendPro Online or PitneyShip is frozen

If SendPro Online or PitneyShip is frozen, you will need to close and reopen it. If you are pasting the address in, edit it before pasting.

If you need further assistance, please contact us.

UPDATED: October 11, 2023